What systems does DeskTime support?

Windows Vista SP2

Windows 7 SP1 or higher

server OS is supported as well

 

  • Windows users are required to install Microsoft NET framework 4.5.2 in order to run DeskTime.
  • If you want to use DeskTime on Windows XP, you can use our previous DeskTime version - Download here
    • For previous DeskTime version you will need Browser extensions to track website URLs - get extensions here

Starting from version 10.6

 

  • If you’re running an older version, please contact our support: support@desktime.com

Ubuntu LTS versions starting from version 16.04

 

  • For Ubuntu 14.04  LTS and other desktop enviroments, please use an older DeskTime app version, available here.
  • For all Linux DeskTime app versions you will need Browser extensions to track website URLs - get extensions here
  • In case your Linux computer is missing a package or the DeskTime app doesn't work, although you have logged in through the Desktime app, type in the desktop terminal "sudo apt-get install -f" and all the necessary packages will be installed automatically. 

Ā© 2011 - 2019 DeskTimeĀ® Inc. All Rights reserved.